MLAG - Dell

Using MLAG in Dell Networks
A deployment guide for Dell Networking switches (version 1.1)
Dell Engineering
March 2014
January 2014
dd
vERSION
A Dell Deployment and Configuration Guide
Revisions
Date
Description
Author
March, 2014
1.1 includes limitation of partner switches, added clarification of
types of ports that can be used in peer-links, and changes to
topologies supported in new appendix.
Victor Teeter
January, 2014
1.0 Initial Release
Victor Teeter
PAPER IS FOR INFORMATIONAL PURPOSES ONLY, AND MAY CONTAIN TYPOGRAPHICAL ERRORS AND TECHNICAL
INACCURACIES. THE CONTENT IS PROVIDED AS IS, WITHOUT EXPRESS OR IMPLIED WARRANTIES OF ANY KIND.
© 2014 Dell Inc. All rights reserved. Reproduction of this material in any manner whatsoever without the express written permission
of Dell Inc. is strictly forbidden. For more information, contact Dell.
PRODUCT WARRANTIES APPLICABLE TO THE DELL PRODUCTS DESCRIBED IN THIS DOCUMENT MAY BE FOUND AT:
http://www.dell.com/learn/us/en/19/terms-of-sale-commercial-and-public-sector Performance of network reference
architectures discussed in this document may vary with differing deployment conditions, network loads, and the like. Third party
products may be included in reference architectures for the convenience of the reader. Inclusion of such third party products does
not necessarily constitute Dell’s recommendation of those products. Please consult your Dell representative for additional
information.
Trademarks used in this text: Dell™, the Dell logo, PowerConnect™, OpenManage™, EqualLogic™, Compellent™, and Force10™
®
®
are trademarks of Dell Inc. Other Dell trademarks may be used in this document. Cisco Nexus®, Cisco MDS , Cisco NX-0S , and
®
®
®
®
®
other Cisco Catalyst are registered trademarks of Cisco System Inc. Microsoft , Windows , Windows Server , Internet Explorer ,
®
®
®
MS-DOS , Windows Vista and Active Directory are either trademarks or registered trademarks of Microsoft Corporation in the
®
®
United States and/or other countries. Broadcom and NetXtreme are registered trademarks of Broadcom Corporation. Qlogic is a
registered trademark of QLogic Corporation. Other trademarks and trade names may be used in this document to refer to either
the entities claiming the marks and/or names or their products and are the property of their respective owners. Dell disclaims
proprietary interest in the marks and names of others.
2
.
Using MLAG in Dell Networks
Table of Contents
Revisions ............................................................................................................................................................................................. 2
Executive Summary .......................................................................................................................................................................... 4
1
Introduction ................................................................................................................................................................................ 5
2
Caveats for Enabling MLAG ..................................................................................................................................................... 6
3
Supported Topologies .............................................................................................................................................................. 8
4
Single-Tier Example .................................................................................................................................................................. 9
5
Two-Tier Example ................................................................................................................................................................... 13
Appendix ........................................................................................................................................................................................... 19
3
.
A.1
Unsupported Configurations ...................................................................................................................................... 19
A.2
Future support of MLAG with similar technologies ................................................................................................ 19
A.3
Additional Resources .................................................................................................................................................... 20
Using MLAG in Dell Networks
Executive Summary
Multi-switch Link Aggregation or MLAG is a feature that allows two Dell Networking switches to act as a
single switch, provides multiple paths across the network with benefits like:



Failover in cases of failed cables or switches
Increased bandwidth of up to double the bandwidth of a single switch
Elimination of port blocking as well as reconvergence delays of spanning tree
An MLAG domain is created by connecting a Dell Networking switch to another Dell Networking switch
through Peer-Link ports to create MLAG peers (the two connected switches). Other switches directly
connected to the MLAG peers are unaware that they are connecting to two switches. Two switches
appear as a single switch on the network.
All links in the MLAG can carry data traffic across many physically diverse topologies. In the case of a link
or switch failure, traffic continues to flow with minimal disruption. MLAG optimnizes availability and
bandwidth between attached devices in Dell’s Datacenter and Campus networking solutions.
The following Dell Networking N-series switches support MLAG and may be used in building the
configurations in this white paper:
N2024
N3024
N4032
N2024P
N3024P
N4032F
N2048
N3024F
N4064
N2048P
N3048
N4064F
N3048P
4
.
Using MLAG in Dell Networks
1
Introduction
MLAGs provide an active-active split aggregation deployment across two switches acting as one. MLAG
creates a more resilient network with higher bandwidth capabilities. This white paper discusses MLAGs,
how and when they are used, caveats to look out for, and instructions on how to implement MLAG into
your network.
Figure 1 below shows two very basic examples of MLAG domains. In both examples, peer switches are
linked together with a special LAG (one or more cables as denoted by the red line in the pictures below),
called a Peer-Link. Any non-management port on the switch can be used in the Peer-Link. With the
Peer-Link configured, the two switches appear as a single switch to partner switches upstream and
downstream. Each partner switch contains MLAGs that are simply LAGs (link aggregation groups) whose
cables are split between the two peers. Primary and secondary peer roles are chosen automatically by the
program when MLAG is enabled.
Simple L2 MLAG
MLAG domain
Secondary MLAG peer
Primary MLAG peer
Peer-Link
MLAG
MLAG domain
appears as a single
logical switch to
partner switches on
the network
Partner Switch
L3 MLAG with mulitple
partner switches
MLAG domain
Secondary MLAG peer
Primary MLAG peer
Peer-Link
Partner Switch
Figure 1
5
.
Using MLAG in Dell Networks
MLAG
MLAG
Two examples of a single-tier MLAG topology
Partner Switch
2
Caveats for Enabling MLAG
There are a few limitations in implementing MLAGs:




Two identical switch models are required to create MLAG peers. This means an N2048 can only be
peered with another N2048, an N3024 with another N3024, and so on.
Peer devices must use the same expansion module type if ports from the expansion module are to
be part of the MLAG interface.
Neither of the two switches used as MLAG peers may be stacked with other switches.
MLAG status using the show vpc brief command is only run from the primary MLAG peer
when both the primary and secondary peer information is required.
See the switch User Guide for additional information.
Note: Run the show vpc brief command only from the Primary MLAG peer. This provides
information on both peer switches.
2.1
Consistency of MLAG Peers
As mentioned in the section above, the two switches to be used as MLAG peers must be identical models,
as well as any expansion module that is used in the MLAG peer-link setup. There are also six areas in the
software configuration that must be given special attention to ensure they contain identical information
prior to enabling the MLAG. These areas are reflected in Figure 2.
MLAG peer
peer
link
Link Aggregation
=
=
=
=
=
=
Spanning Tree
MLAG Port-channels
Interfaces
VLANs
Firmware
Figure 2
6
.
Using MLAG in Dell Networks
Consistent MLAG peer configurations
MLAG peer
Link Aggregation
Spanning Tree
MLAG Port-channels
Interfaces
VLANs
Firmware
Change any settings mentioned below on both the MLAG peers when required. Enable MLAG only after
the above settings are configured on the two peer switches.
It is also recommended for MLAG to be temporarily disabled in order to make subsequent changes to the
above settings.
Note: Be sure to schedule down time if making changes that impact traffic or cause data loss.
Note: Failure to make these areas identical may cause sporadic traffic issues on the network which are
difficult to troubleshoot.
Option category
Settings that need to match on both MLAG peers
Link Aggregation
Hashing mode
Minimum links
Static/dynamic LAG
LACP parameters
o Actor parameters
o Admin key
o Collector max-delay
o Partner parameters
Bpdufilter
Bpduflood
Auto-edge
TCN-guard
Cost
Edgeport
Root guard
Loop guard
STP Version
STP MST VLAN configuration
STP MST instance configuration (instance ID,
port priority, port cost/mode)
Port-channel mode
Link speed
Duplex mode
MTU
Bandwidth
VLAN configuration
PFC configuration
CoS queue assignments
MLAG VLANs must be configured on both
MLAG peers, and connect to two partner LAGs.
Both peers require the same firmware version
to operate correctly.
FDB entry aging timers
Static MAC entries
ACL configuration
Spanning Tree
1.
MLAG Port-channels
Interfaces
VLANs
Firmware
Misc.
Table 1
7
.
Using MLAG in Dell Networks
Specific configuration options to be equal among MLAG peers
3
Supported Topologies
MLAG topologies contain several options. They can be a single layer (only one pair of MLAG peer switches)
or two layers (two pair of MLAG peer switches). The peer-link between peers can have anywhere from 1
to 8 active interfaces to create the link. With these and other variables, there are dozens of ways to setup
an MLAG. Table 2 lists all supported topology options.
Topological parameter
Supported options
# of MLAG domains per switch
# of peer switches per MLAG domain
# of interfaces per MLAG
# of interfaces per Peer-Link
# of MLAGs connecting to MLAG domain
# of layers
Table 2 Parameters for an MLAG topology
1
2
2 to 8
1 to 8
Limited only by number of ports available
1 or 2
Figure 3 shows just a few examples of MLAG topologies that can be built using the MLAG feature. The red
lines show the peer-lnks between the primary and secondary peer switches.
3 partner switches
1 partner switch
2 tier
(2 layer, full mesh)
2 partner switches
SYS MASTER
FAN PSU
Force10 S4810P
RS-232
52
0
2
4
6
8
10
12
14
16
18
20
22
24
SFP+
26
28
30
32
34
36
38
40
42
44
46
48
QSFP+
60
56
LNK
ETHERNET
VLTi
ACT
SYS MASTER
FAN PSU
Force10 S4810P
RS-232
52
0
2
4
6
Figure 3
8
.
Using MLAG in Dell Networks
Examples of MLAG topologies
8
10
12
14
16
18
20
22
24
SFP+
VLTi
26
28
30
32
34
36
38
40
42
44
46
48
QSFP+
60
56
LNK
ETHERNET
ACT
2 layer (MLAG and VLT)
4
Single-Tier Example
This example shows the configuration of the two MLAG peers with two MLAG partners. The default
spanning tree configuration is used and spanning tree is disabled on the peer link.
Primary MLAG peer
(27)
(1/0/1)
Peer-Link
(48)
N3048
Partner Switch A
(47)
MLAG
Secondary MLAG peer
(12)
N3048
MLAG
(29)
(1/0/1)
Partner Switch B
(30)
(28)
Figure 4
(11)
Single tier MLAG topology
To configure the two MLAG peers in the basic configuration, follow the steps below:
1.
9
.
Enter the following commands on both peer switches before enabling MLAG (using
the feature vpc command) on each one. Each column below contains commands
that can be cut and pasted into a CLI session.
Primary MLAG Peer (N3048)
Secondary MLAG Peer N3048)
Description of commands
configure
vlan 30
exit
configure
vlan 30
exit
 Create a VLAN for MLAG and all
partner traffic
interface port-channel 1
description "MLAG-Peer-Link"
spanning-tree disable
switchport mode trunk
vpc peer-link
exit
interface port-channel 1
description "MLAG-Peer-Link"
spanning-tree disable
switchport mode trunk
vpc peer-link
exit
 Configure the port channel for
the peer link
- must be trunk mode
interface tengigabitethernet 1/0/1
channel-group 1 mode active
description "MLAG-Peer-Link"
exit
interface tengigabitethernet 1/0/1
channel-group 1 mode active
description "MLAG-Peer-Link"
exit
 Identify and configure the peer
link interface
interface port-channel 30
switchport mode trunk
interface port-channel 30
switchport mode trunk
 Create a LAG for partner switch
A to pass traffic
Using MLAG in Dell Networks
10
.
Primary MLAG Peer (N3048)
Secondary MLAG Peer N3048)
switchport trunk native vlan 30
vpc 30
exit
switchport trunk native vlan 30
vpc 30
exit
interface port-channel 40
switchport mode trunk
switchport trunk native vlan 30
vpc 40
exit
interface port-channel 40
switchport mode trunk
switchport trunk native vlan 30
vpc 40
exit
 Create a LAG (port-channel) for
partner switch B to pass traffic
interface gigabitethernet 1/0/47
channel-group 30 mode active
description "MLAG-Partner-link"
exit
interface gigabitethernet 1/0/11
channel-group 30 mode active
description "MLAG-Partner-Link"
exit
 Assign interfaces to connect to
partner A LAG (channel-group)
interface gigabitethernet 1/0/48
channel-group 40 mode active
description "MLAG-Partner-Link"
exit
interface gigabitethernet 1/0/12
channel-group 40 mode active
description "MLAG-Partner-Link"
exit
 Assign interfaces to connect to
partner B LAG (channel-group)
interface range gi1/0/xx-yy
switchport mode access
switchport access vlan 30
exit
interface range gi1/0/xx-yy
switchport mode access
switchport access vlan 30
exit
 Assign additional ports to the
VLAN only for hosts that will be
using the MLAG
feature vpc
vpc domain 1
peer-keepalive enable
exit
feature vpc
vpc domain 1
peer-keepalive enable
exit
 Enable the MLAG
Partner Switch A
Partner Switch B
Description of commands
configure
vlan 30
exit
configure
vlan 30
exit
 create same VLAN on partners
interface port-channel 1
switchport mode trunk
switchport trunk native vlan 30
exit
interface port-channel 1
switchport mode trunk
switchport trunk native vlan 30
exit
 configure the port channel
trunk for the partner link
interface gi1/0/27
channel-group 1 mode active
exit
interface gi1/0/29
channel-group 1 mode active
exit
 Assign interfaces to MLAG
(channel-group)
interface gi1/0/28
channel-group 1 mode active
exit
interface gi1/0/30
channel-group 1 mode active
exit
 Assign interfaces to MLAG
(channel-group)
interface range gi1/0/xx-yy
switchport mode access
switchport access vlan 30
exit
interface range gi1/0/xx-yy
switchport mode access
switchport access vlan 30
exit
 Assign additional ports to the
VLAN only for hosts that will be
using the MLAG
Using MLAG in Dell Networks
Description of commands
 Must use a native VLAN
 Assign a unique id for partner
switch A
 Assign a unique id for partner
switch B
Note: Interfaces used to connect each peer to the partner switch LAG do not need to match on each
peer. For instance, in the example above, one partner LAG interface connects to 1/0/47 on the primary
peer while the other interface connects to 1/0/11 on the secondary peer.
2. Connect all cables as shown in Figure 4.
3. Run the show vpc brief command on either of the two MLAG peers to see which
peer is the primary MLAG peer.
4. Run the show vpc brief command again from the primary switch to display all
information for both peers.
Note: The partner switches must be configured with MLAGs and connected to the MLAG peers, or the
“Number of VPCs operational” in the show vpc brief command shows 0.
Primary MLAG Peer
show vpc brief
VPC admin status................................... Enabled
Keep-alive admin status....................... Enabled
VPC operational status......................... Enabled
Self role.................................................. Secondary
Peer role................................................ Primary
Peer detection admin status............... Disabled
Peer-Link details
----------------Interface.................................................. Po1
Peer-link admin status......................... Enabled
Peer-link STP admin status................. Disabled
Configured VLANs................................. 1,30
Egress tagged VLANs............................ 30
Peer-Link details
----------------Interface.................................................. Po1
Peer-link admin status......................... Enabled
Peer-link STP admin status................. Disabled
Configured VLANs................................. 1,30
Egress tagged VLANs............................ 30
VPC Details
----------Number of VPCs configured...................... 2
Number of VPCs operational..................... 2
VPC Details
----------Number of VPCs configured...................... 2
Number of VPCs operational..................... 2
VPC id# 30
----------Interface.................................................... Po30
Configured VLANs.................................. 1,30
VPC interface state................................. Active
VPC id# 30
----------Interface.................................................... Po30
Configured VLANs.................................. 1,30
VPC interface state................................. Active
Local Members
----------------Gi1/0/47
Status
-----Up
Local Members
----------------Gi1/0/11
Peer Members
---------------Gi1/0/11
Status
-----Up
Peer Members
Status
---------------- -----< * run command from Primary for this information >
VPC id# 40
11
.
Secondary MLAG Peer
show vpc brief
VPC admin status............................... Enabled
Keep-alive admin status................... Enabled
VPC operational status..................... Enabled
Self role................................................ Primary
Peer role.............................................. Secondary
Peer detection admin status........... Disabled
Using MLAG in Dell Networks
VPC id# 40
Status
-----Up
Primary MLAG Peer
Secondary MLAG Peer
----------Interface.............................................. Po40
Configured VLANs............................ 1,30
VPC interface state........................... Active
----------Interface............................................ Po40
Configured VLANs.......................... 1,30
VPC interface state......................... Active
Local Members
----------------Gi1/0/48
Status
-----Up
Local Members
----------------Gi1/0/12
Peer Members
---------------Gi1/0/12
Status
-----Up
Peer Members
Status
---------------- -----< * run command from Primary for this information >
Status
-----Up
Note: Running the show vpc brief command on the primary shows the complete status of both peer
switches. Running the show vpc brief command on the secondary only shows the status of the
secondary.
Results of the command should be the same as shown above. All member ports must show “UP”, and the
“VPC interface state” must show “Active”. The show interface port-channel is another helpful tool to
let you know if the configured LAG ports are up and running. This command can be run on both the
primary and secondary peers on a single layer MLAG topology. If correctly configured, the port(s) in the
LAG are listed with an Active status. If there are any inactive ports, check for cabling or configuration
issues.
Single-tier MLAG Peer
show interface port-channel 40
Channel Ports
Ch-Type Hash Type Min-links Local Prf
------- ----------------------------- -------- --------- --------- ---Po40
Active: Gi1/0/48
Dynamic 7
1
Disabled
Hash Algorithm Type
1 - Source MAC, VLAN, EtherType, source module and port Id
2 - Destination MAC, VLAN, EtherType, source module and port Id
3 - Source IP and source TCP/UDP port
4 - Destination IP and destination TCP/UDP port
5 - Source/Destination MAC, VLAN, EtherType, source MODID/port
6 - Source/Destination IP and source/destination TCP/UDP port
7 - Enhanced hashing mode
12
.
Using MLAG in Dell Networks
5
Two-Tier Example
Figure 5 shows a logical topology for a 2-tier fully meshed MLAG, offering full redundancy across all four
MLAG peers. Six Dell N3024s are used for the example, however the same principals apply and the same
commands can be used on the N2000 and N4000 series switches.
A.
1
3
5
7
9
11
13
15
17
19
2
4
6
8
10
12
14
16
18
20
21
1
LNK 23 ACT
2
Stack No.
LNK
22
ACT
24 COMBO P
1
SFP+
2
= MLAG
B.
1
3
5
7
9
11
13
15
17
19
2
4
6
8
10
12
14
16
18
20
21
1
LNK 23 ACT
2
Stack No.
LNK
22
ACT
24 COMBO P
1
SFP+
C.
Peer-Link
1
3
5
7
9
11
13
15
17
19
2
4
6
8
10
12
14
16
18
20
21
1
LNK 23 ACT
2
Stack No.
LNK
ACT
2
22
24 COMBO P
1
SFP+
2
2 tier
(2 layer, full mesh)
D.
1
3
5
7
9
11
13
15
17
19
2
4
6
8
10
12
14
16
18
20
21
1
LNK 23 ACT
2
Stack No.
LNK
F.
Figure 5
22
24 COMBO P
ACT
1
SFP+
E.
Peer-Link
1
3
5
7
9
11
13
15
17
19
2
4
6
8
10
12
14
16
18
20
21
1
LNK 23 ACT
2
Stack No.
LNK
ACT
2
1
3
5
7
9
11
13
15
17
19
2
4
6
8
10
12
14
16
18
20
21
24 COMBO P
1
SFP+
2
1
LNK 23 ACT
2
Stack No.
LNK
22
22
ACT
24 COMBO P
1
SFP+
2
Logical topology of a 2-tier full mesh configuration
Figure 6 shows the physical layout of the same topology as it might appear in a rack, including cabling and
attached hosts that need to communicate across the MLAG. The same color scheme is used for the cables
in Figure 6 that was used to show logical connections in Figure 5.
(23)
(13-14)
1
Ports are denoted by the
port # in parenthesis.
Example:
gigabitethernet 1/0/23
is shown as (23)
3
5
7
9
11
13
15
17
19
21
1
LNK 23 ACT
A.
2
Stack No.
LNK
2
4
6
8
10
12
5
7
9
11
14
16
18
20
13
15
17
19
22
ACT
1
24 COMBO P
SFP+
2
(1-2)
1
3
21
1
LNK 23 ACT
(14)
B.
2
4
6
8
10
12
16
18
20
22
ACT
1
24 COMBO P
SFP+
Server
2
(Te 1)
(13)
(1-2)
C.
14
2
Stack No.
LNK
1
3
5
7
9
11
13
15
17
19
2
4
6
8
10
12
14
16
18
20
1
3
5
7
9
13
15
17
19
21
1
LNK 23 ACT
2
Stack No.
LNK
22
ACT
1
24 COMBO P
SFP+
2
(Te 1)
D.
11
1
LNK 23 ACT
(14)
(1-2)
4
6
8
10
12
3
5
7
9
11
16
18
20
15
17
19
22
13
1
1
2
4
6
8
1
3
5
7
10
9
12
11
14
13
16
18
20
15
17
19
22
.
ACT
1
24 COMBO P
SFP+
2
(Te 1)
21
1
LNK 23 ACT
2
Stack No.
LNK
4
6
8
10
12
14
16
18
Physical cabling of a 2-tier full mesh configuration
Using MLAG in Dell Networks
2
Stack No.
20
22
24 COMBO P
(24)
13
2
LNK 23 ACT
LNK
2
Figure 6
SFP+
(Te 1)
21
(13-14)
F.
ACT
24 COMBO P
(13)
(1-2)
1
14
2
Stack No.
LNK
2
E.
21
ACT
1
SFP+
2
PC
In a full mesh, all eight ports joined together in the MLAG (four blue cables) are in the same port channel
to achieve maximum redundancy.
To configure the 2-tier in a full mesh configuration, follow the steps below:
1.
Enter the commands below for each corresponding switch in the topology.
2. Cable the configuration as shown.
3. Enable MLAG (using the feature vpc command) on each switch.
Similar commands are performed on all four MLAG peer switches. MLAG peers B and C are required to be
consistent in their configurations following the guidelines set in Consistency of MLAG peers. MLAG peers
D and E also follow the same requirements for consistency. Though MLAG partner switches A and F may
have similar configurations in this particular scenario, they have no such consistency requirements to each
other or to the peer switches.
Each column below contains commands that can be cut and pasted into a CLI session if using the same
topology as described in this example. Command sections are color-coded to allow easier comparisons
between the BC MLAG peers and the DE MLAG peers.
14
.
MLAG Peer B
MLAG Peer C
Description of commands
configure
vlan 30
exit
configure
vlan 30
exit
 Create a VLAN for MLAG and
all partner traffic
interface port-channel 1
description "MLAG-Peer-Link"
spanning-tree disable
switchport mode trunk
vpc peer-link
exit
interface port-channel 1
description "MLAG-Peer-Link"
spanning-tree disable
switchport mode trunk
vpc peer-link
exit
 Configure the port channel for
the BC peer link
- must be trunk mode
interface tengigabitethernet 1/0/1
channel-group 1 mode active
description "MLAG-Peer-Link"
exit
interface tengigabitethernet 1/0/1
channel-group 1 mode active
description "MLAG-Peer-Link"
exit
 Identify and configure the BC
peer link interfaces
interface port-channel 40
switchport mode trunk
switchport trunk native vlan 30
vpc 40
exit
interface port-channel 40
switchport mode trunk
switchport trunk native vlan 30
vpc 40
exit
 Create a LAG (port-channel)
for partner switch DE to pass
traffic
 Assign a unique id for partner
switch DE
interface port-channel 50
switchport mode trunk
switchport trunk native vlan 30
vpc 50
exit
interface port-channel 50
switchport mode trunk
switchport trunk native vlan 30
vpc 50
exit
 Create a LAG (port-channel)
for partner switch A to pass
traffic
 Assign a unique id for partner
switch A
Using MLAG in Dell Networks
15
.
MLAG Peer B
MLAG Peer C
interface gigabitethernet 1/0/1
channel-group 40 mode active
description "MLAG-Partner-Link"
exit
interface gigabitethernet 1/0/1
channel-group 40 mode active
description "MLAG-Partner-Link"
exit
interface gigabitethernet 1/0/2
channel-group 40 mode active
description "MLAG-Partner-Link"
exit
interface gigabitethernet 1/0/2
channel-group 40 mode active
description "MLAG-Partner-Link"
exit
 Assign interfaces to connect
to partner D’s half of full mesh
LAG
interface gigabitethernet 1/0/14
channel-group 50 mode active
switchport mode trunk
switchport trunk allowed vlan 30
exit
interface gigabitethernet 1/0/13
channel-group 50 mode active
switchport mode trunk
switchport trunk allowed vlan 30
exit
 Assign interfaces to VLAN that
will connect to partner A’s LAG
feature vpc
vpc domain 1
peer-keepalive enable
exit
feature vpc
vpc domain 1
peer-keepalive enable
exit
 Enable the MLAG
MLAG Peer D
MLAG Peer E
Description of commands
configure
vlan 30
exit
configure
vlan 30
exit
 Create a VLAN for MLAG and
all partner traffic
interface port-channel 1
description "MLAG-Peer-Link"
spanning-tree disable
switchport mode trunk
vpc peer-link
exit
interface port-channel 1
description "MLAG-Peer-Link"
spanning-tree disable
switchport mode trunk
vpc peer-link
exit
 Configure the port channel for
the DE peer link
- must be trunk mode
interface tengigabitethernet 1/0/1
channel-group 1 mode active
description "MLAG-Peer-Link"
exit
interface tengigabitethernet 1/0/1
channel-group 1 mode active
description "MLAG-Peer-Link"
exit
 Identify and configure the DE
peer link interfaces
interface port-channel 40
switchport mode trunk
switchport trunk native vlan 30
vpc 40
exit
interface port-channel 40
switchport mode trunk
switchport trunk native vlan 30
vpc 40
exit
 Create a LAG (port-channel)
for partner switch BC to pass
traffic
 Assign a unique id for partner
switch BC
interface port-channel 60
switchport mode trunk
switchport trunk native vlan 30
vpc 60
exit
interface port-channel 60
switchport mode trunk
switchport trunk native vlan 30
vpc 60
exit
 Create a LAG (port-channel)
for partner switch F to pass traffic
interface gigabitethernet 1/0/1
channel-group 40 mode active
interface gigabitethernet 1/0/1
channel-group 40 mode active
 Assign interfaces to connect
to partner B ‘s half of full mesh
Using MLAG in Dell Networks
Description of commands
 Assign interfaces to connect
to partner E’s half of full mesh
LAG
-put both 13 and 14 into same
LAG 50
 Assign a unique id for partner
switch F
MLAG Peer D
MLAG Peer E
description "MLAG-Partner-Link"
exit
description "MLAG-Partner-Link"
exit
Description of commands
MLAG
interface gigabitethernet 1/0/2
channel-group 40 mode active
description "MLAG-Partner-Link"
exit
interface gigabitethernet 1/0/2
channel-group 40 mode active
description "MLAG-Partner-Link"
exit
 Assign interfaces to connect
to partner C ‘s half of full mesh
LAG
interface gigabitethernet 1/0/14
channel-group 60 mode active
switchport mode trunk
switchport trunk allowed vlan 30
description "MLAG-Partner-Link"
exit
interface gigabitethernet 1/0/13
channel-group 60 mode active
switchport mode trunk
switchport trunk allowed vlan 30
description "MLAG-Partner-Link"
exit
 Assign interfaces to VLAN that
will connect to partner F’s LAG
-put both 13 and 14 into same
LAG 60
feature vpc
vpc domain 1
peer-keepalive enable
exit
feature vpc
vpc domain 1
peer-keepalive enable
exit
 Enable the MLAG
Partner Switch A
Partner Switch F
Description of commands
configure
vlan 30
exit
configure
vlan 30
exit
 create same VLAN on partners
interface port-channel 1
switchport mode trunk
exit
interface port-channel 1
switchport mode trunk
exit
 configure the port channel
trunks for the partner links
interface gi1/0/13
channel-group 1 mode active
exit
interface gi1/0/13
channel-group 1 mode active
exit
 Assign first interface to LAG
(channel-group)
interface gi1/0/14
channel-group 1 mode active
exit
interface gi1/0/14
channel-group 1 mode active
exit
 Assign second interface to
LAG (channel-group)
interface gi1/0/23
switchport mode access
switchport access vlan 30
exit
interface gi1/0/24
switchport mode access
switchport access vlan 30
exit
 Assign additional ports to the
VLAN only for hosts that will be
using the MLAG
Port 23 in switch A connects to the Server, and port 24 in switch F connects to the PC client.
Connect all cables as shown in Figure 6.
Run the show vpc brief command on either of the two MLAG peers to see which peer is the primary
MLAG peer. Run the show vpc brief command again from the primary switch to display all information
for both peers.
16
.
Using MLAG in Dell Networks
Note: Interfaces used to connect each peer to the partner switch LAG do not need to match on each
peer. For instance, in the example above, one partner LAG interface connects to 1/0/47 on the primary
peer while the other interface connects to 1/0/11 on the secondary peer.
Note: The partner switches must be configured with LAGs and connected to the MLAG peers, or the
“Number of VPCs operational” in the show vpc brief command will show 0.
MLAG Peer B (Primary Peer)
MLAG Peer C (Secondary Peer)
show vpc brief
show vpc brief
VPC admin status................................... Enabled
Keep-alive admin status....................... Enabled
VPC operational status......................... Enabled
Self role.................................................... Primary
Peer role.................................................. Secondary
Peer detection admin status............... Disabled
VPC admin status................................... Enabled
Keep-alive admin status........................ Enabled
VPC operational status.......................... Enabled
Self role..................................................... Secondary
Peer role................................................... Primary
Peer detection admin status................ Disabled
Peer-Link details
----------------Interface.................................................. Po1
Peer-link admin status......................... Enabled
Peer-link STP admin status................. Disabled
Configured VLANs................................ 1,30
Egress tagged VLANs............................ 30
Peer-Link details
----------------Interface.................................................. Po1
Peer-link admin status......................... Enabled
Peer-link STP admin status................. Disabled
Configured VLANs................................. 1,30
Egress tagged VLANs............................ 30
VPC Details
----------Number of VPCs configured...................... 2
Number of VPCs operational..................... 2
VPC Details
----------Number of VPCs configured...................... 2
Number of VPCs operational..................... 2
VPC id# 40
----------Interface................................................ Po40
Configured VLANs............................... 1,30
VPC interface state............................. Active
VPC id# 40
----------Interface................................................ Po40
Configured VLANs............................... 1,30
VPC interface state............................. Active
Local Members
Status
----------------- -----Gi1/0/1
Up
Gi1/0/2
Up
Local Members
Status
----------------- -----Gi1/0/1
Up
Gi1/0/2
Up
Peer Members
---------------Gi1/0/1
Gi1/0/2
Peer Members
Status
---------------- -----< * run command from Primary for this information >
Status
-----Up
Up
VPC id# 50
----------Interface................................................ Po50
Configured VLANs............................... 1,30
VPC interface state............................. Active
17
.
Using MLAG in Dell Networks
VPC id# 50
----------Interface................................................ Po50
Configured VLANs............................... 1,30
VPC interface state............................. Active
Local Members
Status
----------------- -----Gi1/0/14
Up
Local Members
Status
----------------- -----Gi1/0/13
Up
Peer Members
---------------Gi1/0/13
Peer Members
Status
---------------- -----< * run command from Primary for this information >
Status
-----Up
Note: Running the show vpc brief command on the primary shows the complete status of both peer
switches. Running the show vpc brief command on the secondary shows status of the secondary
only.
Results of the command should be the same as shown above. All member ports must show “UP”, and the
“VPC interface state” must show “Active”. The show interface port-channel is another helpful tool to
let you know if the configured LAGs are up and running. This command must also only be run on the
primary peer when used in a two-tier topology. If correctly configured, ports in the primary LAG are listed
with an “Active” status. Inactive ports are usually a sign of a cabling or configuration issue.
MLAG Primary Peers only: B and D
show interface port-channel 40
Channel Ports
Ch-Type Hash Type Min-links Local Prf
------- ----------------------------- -------- --------- --------- ---Po40
Active: Gi1/0/1, Gi1/0/2
Dynamic 7
1
Disabled
Hash Algorithm Type
1 - Source MAC, VLAN, EtherType, source module and port Id
2 - Destination MAC, VLAN, EtherType, source module and port Id
3 - Source IP and source TCP/UDP port
4 - Destination IP and destination TCP/UDP port
5 - Source/Destination MAC, VLAN, EtherType, source MODID/port
6 - Source/Destination IP and source/destination TCP/UDP port
7 - Enhanced hashing mode
Like the show vpc brief command, the show interfaces port-channel command must be run
from the primary peer to receive information from both of the peer switches.
18
.
Using MLAG in Dell Networks
Appendix
A.1
Unsupported Configurations
Figure 7 shows examples of configurations that are not supported. The first topology shows an MLAG
peer attempting to connect with a Dell VLTi peer. The second topology shows an MLAG peer attempting
to connect with a Cisco vPC (or Cisco VSS) peer. Neither peer configurations shown in these scenarios are
supported.
S4810
Force10 S4810P
RS-232
2
4
6
8
10
12
14
16
18
20
22
24
26
28
30
32
34
36
38
40
42
44
46
QSFP+
48
60
56
SFP+
LNK
ETHERNET
ACT
VLTi
Cisco
N3048
X
Peer-Link
R
SYS MASTEFAN PSU
52
0
CISCO NEXUS 2232TP 10GE FABRIC EXTENDER
STAT
1
ID
2
3
4
5
6
7
8
9
10
11 12
13 14
15 16
17 18
19 20
21 22
23 24
25 26
A.2
29 30
31 32
1
2
3
4
5
6
7
8
vPC
LAG
Figure 7
27 28
X
Peer-Link
N3048
LAG
Unsupported peer configurations
Future support of MLAG with similar technologies
Figure 8 below shows MLAG peers on one layer and Dell VLT peers on the second layer, with a full-mesh
LAG. Results from preliminary testing of this configuration have not shown any major issues. Official
support for this configuration is planned for 2014.
LAG
S4810
ER
SYS MAST FAN PSU
Force10 S4810P
RS-232
52
0
2
4
6
8
10
12
14
16
18
20
22
24
26
28
30
32
34
36
38
40
42
44
46
48
SFP+
QSFP+
60
56
LNK
ETHERNET
VLTi
ACT
S4810
RS-232
52
0
2
4
6
8
10
12
14
16
18
20
22
24
26
28
30
32
34
36
38
40
42
44
46
SFP+
LAG
N3048
PeerLink
MLAG
Figure 8
19
.
Mixed LAG configuration
Using MLAG in Dell Networks
ER
SYS MAST FAN PSU
Force10 S4810P
N3048
48
QSFP+
60
56
LNK
ETHERNET
ACT
VLT is a feature similar to MLAG, but is available on the FTOS-based Dell Networking switches like the
S4810. Each peer pair must use the same multi-chassis lag feature. This will provide the network with the
same resiliency and improved bandwidth as when using MLAG in a multi-tier MLAG-only environment.
A.3
Additional Resources
Support.dell.com is focused on meeting your needs with proven services and support.
DellTechCenter.com is an IT Community where you can connect with Dell Customers and Dell
employees for the purpose of sharing knowledge, best practices, and information about Dell products and
installations.
Referenced or recommended Dell publications:
 Dell Networking Support
- http://www.dell.com/support
 Dell TechCenter (community forums and blogs for Dell customers)
- http://delltechcenter.com
 Dell Networking Whitepapers
- http://en.community.dell.com/techcenter/networking/w/wiki/2580.networkingwhitepapers.aspx
 Dell Networking N2000/N3000/N4000 User Guides and Firmware downloads
- http://www.dell.com/support/mysupport/us/en/04#04/Products/ser_stor_net/networking?&_suid=138471814600402061940321
9436666
A.4
Configuration details
This paper was compiled using the following components and versions.
Component
Description
Dell Networking firmware versions D.9.29.2, 6.0.0.2, 6.0.0.4
Switch
20
.
Using MLAG in Dell Networks
Dell Networking N2000, N3000, and N4000 series
About Dell
Dell is a worldwide leader in data center and campus solutions which includes the manufacturing and
distribution of servers, network switches, storage devices, personal computers, and related hardware and
software. For more information on these and other products, please visit the Dell website at
http://www.dell.com.
21
.
Using MLAG in Dell Networks