1.2_ Intro to Parametric Modeling: Manipulating Terrain

Department of Landscape Architecture
Graduate School of Design
Harvard University
INSTRUCTIONS:
COMMANDS:
1.2_ Intro to Parametric Modeling: Manipulating Terrain
September 14, 2011
T opics C o v e r e d :
1. Representational analogs for terrain and topography
i. Contour plan or model
ii. Sequential sections
iii. Spot elevations or point clouds
iv. Meshes
v. Shaded relief
2. Parametrically manipulating terrain
i. Attractor-based simulations
ii. Patterning with image heightfields
iii. Parametric patterning
INSTRUCTIONS:
SOFTWARE:
Rhino, Adobe Illustrator
Rhino, Adobe Illustrator
Rhino, Adobe Illustrator
Rhino, Grasshopper, RhinoTerrain
COMMANDS:
Representational analogs for terrain and topography
1. Building upon the GIS-generated surface analogs discussed last
week, this week we will look at ways of drawing landform that
assist in expressing its fluidity and dynamic nature. Central to this
discussion is the idea that all reproductions of landforms in nature
or design environments are analogs. That is, they are abstractions:
reduced so as to accurately convey some singular property of
landform (such as slope, contour interval, structure, materiality, etc.).
2. Surface/Landform Analogs:
i. Contour/grading plan or contour model
Contour (Curve menu > Curve from Objects > Contour) Perform from
Front viewport for plan contours with Ortho mode on.
Use “Week 3 - color gradient contour.gh” to apply a color gradient to
contours. To export to Illustrator, File > Export Selected > select AI
ii. Sequential sections
Contour (Curve menu > Curve from Objects > Contour) Perform from
Top viewport. Optional: In Illustrator, change the stroke to fill to show a
solid section profile
iii. Spot elevations or points: You cannot bring point objects into
Illustrator because they cannot display a stroke or a fill. You
must first apply a small circle to each point that can be filled
in. Grasshopper makes this very simple.
Open “Week 3 - points for exporting to AI.gh” in Grasshopper. Select
the points you wish to show in Illustrator. Open the file in Illustrator and
invert the stroke and fill.
INSTRUCTIONS:
COMMANDS:
iv. Meshes
For meshes, simply export the mesh surface to Illustrator. (File > Export
Selected). For surfaces, ExtractWireframe (Curve > Curve from Objects
> Extract Wireframe) and then export. It also helps to extract the mesh
or surface outline: MeshOutline (Curve > Curve from Objects > Mesh
Outline) or DupBorder (Curve > Curve from Objects > Duplicate Border)
v. Shaded Relief (Hillshade)
Render. It helps to add a directional light as well (Render menu > Create
Directional Light) to give highlight and shadow. Adjust the Shadow
Intensity of the light (Properties window > Light > Shadow Intensity). If
you are going to combine the rendering with linework, make sure your
background is transparent in Tools > Options > Rhino Render
Parametrically Manipulating Terrain
File > Open
1. Open “Week 3_start.3dm,” found at goliath.design.harvard.edu\
Public\Courses\2241\2011\Tutorial Base Materials\Week 3 Manipulating Terrain
2. Create a rectangle that is 4000 m long by 3000 m tall. Move the
rectangle to a place on the landform that you find topographically or
contextually interesting.
3. Drape points over the RhinoTerrain landform within the rectangle.
4. So the points you created are more easily visible, adjust the way that
Rhino displays points in the Shaded Viewport.
5. Grasshopper is a plugin for Rhino that allows you to link several
different operations and commands together in a process or
flow chart (called “Spaghetti Wiring” to Grasshopper users). By
incorporating numeric sliders and automatically recalculating
solutions, Grasshopper allows you to design parametrically in Rhino.
That is, unlike Rhino’s native capabilities, which almost always
require you to remodel something in order to edit it, Grasshopper
enables an endless number of permutations, and does so quickly. For
more information on Grasshopper, see the PDF manuals in the 2241
folder on Goliath. Open Grasshopper.
6. Attractor-based simulation:
i. Open “Week 3 - basic attractor.gh”
ii. Follow the notes on the yellow stickies to adjust the
parameters
Rectangle (Curve menu > Rectangle > Corner to Corner)
Move
DrapePt, Set Spacing=5
Tools > Options > Appearance > Advanced Settings > Shaded > Objects >
Points, set Point Style to ‘Solid Square” and Point Size to 1.
Grasshopper
In Grasshopper: File > Open
1. Right click on the box that says Pt and Set Multiple Points, then
select the points you just made in the Rhino window
1.
3.
2. Right click the box that says Attractor 1 and Set One Point, then
select one of the points on the Point Attractors layer. You can move
this point around if you like by dragging it. (make sure to try moving
it up and down along the Z-axis as well)
3. Drag this slider to adjust the falloff radius around the attractor point
2.
that affects how much of the surface is changed.
INSTRUCTIONS:
COMMANDS:
7. Patterning with Image Heightfields
i. Create a surface from an image in Rhino using Heightfield from
Image. Select one of the images on Goliath or use your own.
Use the rectangle you previously drew as a guide. Images for
heightfields work best when they are black and white, highcontrast (white forms a hill, black a valley). Blurry images
produce smoother results while sharper images produce
sharper landforms.
ii. Open “Week 3 - mesh plus surface addition.gh”
iii. Follow the notes on the yellow stickies
Heightfield (Surface menu > Heighfield from Image)
Sample Points: 500x500, Height: 100 inches, Interpolate Points
In Grasshopper: File > Open
In Grasshopper: File > Open
1. Right click on the box that says Pt and Set Multiple Points, then
select the points you just made in the Rhino window
1.
2. Right click the box that says Srf and Set One Surface, then select the
surface you just made with Heightfield from Image
3. Drag this slider to adjust the multiplier for how intensely the
Heightfield from Image surface affects the original surface
2.
3.
8. Parametric Patterning
i. This exercise uses Grasshopper to create a 2D pattern from
which you will generate a heightfield that affects the original
landform as in the previous step.
ii. Open “Week 3 - landform patterning.gh”
iii. Follow the notes on the yellow stickies
In Grasshopper: File > Open
1. Create a point object at the bottom left corner of your rectangle in
Rhino. Right click the Pt box and Set One Point. Adjust the sliders to
control the size and extent of the rectangular grid.
1.
2. Right click the box that says Attractor 1 and select a point on the
Point Attractors layer, or create your own, and Set One Point.
3. Drag this slider to adjust radius of the resultant shapes (circles,
polygons, and rectangles are created, select one of those boxes to
2.
highlight one set).
3.
4.
iv. Experiment with different shapes, sizes, and patterns and
make your own 2D pattern (see detailed instructions at right).
v. Once you have settled upon a 2D pattern, Bake it into Rhino.
4. Adjust the sliders for the rectangular fillet, number of polygons, etc.
When you are satisfied with a geometry, right click one of the layers
and Bake.
INSTRUCTIONS:
COMMANDS:
vi. Select the pattern you have created in Rhino and export it to
Illustrator.
vii. Open the file you just made in Adobe Illustrator. Select all of
the shapes and in the toolbar, click the arrow at the upper
right of the stroke and fill colors to swap the stroke and fill
colors (e.g. change the objects from having a black stroke to
a black fill):
File menu > Export Selected > select AI from pulldown menu
viii. You can also apply a radial gradient to the shapes. You will be
using this pattern as the basis for another Heightfield from
Image surface in Rhino, so applying a gradient to the shapes
will result in a smoother heightfield surface.
Gradient palette > Type = Radial, adjust color sliders
ix. Save the AI file and open it in Photoshop.
Type” is set to All Formats)
x. Create a new layer behind the current layer in Photoshop,
and fill in the background with black.
xi. Export the file as a JPG. Keeping in mind that smooth,
gradient like transitions create smoother landforms in
Rhino, while high-contrast, sharp edges create more defined
landforms in Rhino, your image may look something like this.
You may want to apply a Gaussian blur before exporting so
the image is even smoother.
Set background color to black (RGB=0,0,0), Control+Backspace to fill
Swap fill and stroke shortcut: Shift+X
Illustrator: File > Save, Photoshop: File > Open (Make sure “Files of
xii. Go back to Step 7 of this handout (Patterning with Image
Heightfields), using the image you just created to affect
your original surface. Use the resulting surface to generate
contours, point clouds, etc. as described at the beginning of
this handout.
layer with background color (Command+Delete on a Mac)
File > Save As (Save as JPEG)
Filter > Blur > Gaussian Blur (a value of about 3-4 pixels should be
sufficient)
`