Analyze This! How to use AutoCAD Map 3D for

®
Analyze This! How to use AutoCAD Map 3D for
Geospatial Analysis
Michael Schlosser, Autodesk, Inc
Co-presenter: Warren Medernach, IMAGINiT Technologies
GS314-2
This course is designed for the engineering, CAD and GIS professional and those who are
interested in learning how to analyze their CAD drawings and geospatial data using the powerful geospatial
analysis tools found in AutoCAD Map 3D.
Who Should Attend?
• Engineering, CAD and GIS professionals, existing users of AutoCAD Map 3D
Key Learning
• Enhanced overlay capabilities and the new workflow framework
• Database, tabular joins and the expression builder
• Thematic mapping techniques
• Geospatial buffers and point, line and polygon topologies
• 3d surfaces
About the Speakers:
Michael Schlosser (P.Eng.) is the geospatial subject-matter expert for Autodesk. With 20 years
of experience, he is an expert in the design, development, and implementation of engineering
GIS. He has worked with a variety of clients on their engineering and geospatial implementations
in desktop, server, and Web-based environments, including telecommunications firms, utilities,
transportation, and government departments. He is also skilled in project management; creating
GIS-based simulations and demonstrations; and developing innovative solutions to business
problems.
Warren Medernach is a Geospatial Application Specialist with IMAGINiT Technologies. He has
worked in the Autodesk Reseller channel since 1993. For the last nine years, Warren’s focus has
been in the Mapping and Geospatial disciplines. He is highly skilled in developing techniques for
bridging data between AutoCAD® Map 3D and popular GIS systems and databases. His
experience and excellent communication and people skills assist in his role in the project services
group, where his primary responsibilities include client-specific application development and
geospatial software implementations.
Analyze This! How to use AutoCAD Map 3D for Geospatial Analysis
Problem #1: Using a DWG file containing electrical information for a proposed municipal
subdivision, determine the total length of overhead cable.
Solution: Use the Map Explorer Task Pane and Queries to create a map of overhead cables
and a report file of their corresponding lengths. Use MS Excel to open the resulting file and sum
all cable length values to arrive at the total length of overhead cable.
Step 1. Attach required Drawing Data
Click on the Data icon in the Map Explorer
window and select Attach Source Drawings...
Choose the appropriate Map Alias.
Select the required Drawing files.
Click the Add button to add them to the list of
Selected drawings.
Click OK.
Step 2. Specify the Query conditions
Double-Click the Current Query item in the
Map Explorer to open the Define Query
Dialog.
Click the Property button to open the Property
Condition Dialog.
Choose the Layer option.
Click the Values button to display the list of all
the layers from the attached drawing.
Select the CABLES layer, and click OK twice.
2
Analyze This! How to use AutoCAD Map 3D for Geospatial Analysis
Step 3. Set Query Mode to Draw
Select Draw under the Query Mode area.
Click the Execute Query button to create a
map showing only the overhead cables.
Step 4. Set Query Mode to Report
Double-Click the Current Query item in the
Map Explorer to open the Define Query Dialog
again.
This time, select Report under the Query
Mode area.
Select the Options button to display the Output
Report Options dialog.
Choose the Expressions button to reveal the
Report Template Expressions dialog.
Expand the Properties folder and select the
LENGTH property. Click OK to return to the
Output Report Options dialog then click the
Add button.
Enter a file name in the Output File Name area
and then click OK to return to the Define
Query dialog.
Click the Execute Query button to create the
report file.
Step 5. Use MS Excel to Sum the Lengths
Use MS Excel to open the resulting file from
Step 4. Navigate to the cell just below the last
length value and use the ∑ button (ie
summation) to total the length values.
3
Analyze This! How to use AutoCAD Map 3D for Geospatial Analysis
Problem #2: Using a SHP file containing waterline information as the source data, create a map
that shows the location of all waterlines made of cast iron.
Solution: Use the Display Manager Task Pane and Queries to retrieve waterlines where the
material Type is CAST IRON.
Step 1. Connect to Feature data
Click on the Data button in the
Display Manager and select
Connect to Data to open the Data
Connect Task Pane.
Select the Add SHP Connection
option and specify the path to the
folder containing the required SHP
file. Click the Connect button.
Select the waterlines Schema then
click the Add to Map button to add
the waterlines to the map.
Step 2. Specify Query conditions
Return to the Display Manager and
right-click on the waterlines layer.
Then select the Query to Filter data
option to open the Create Query
dialog.
In the Create Query dialog, select
‘TYPE’ from the Property pulldown
menu.
Select the ‘=’ button for the
comparison operator.
Enter a comparison value of ‘CAST
IRON’.
Click OK.
4
Analyze This! How to use AutoCAD Map 3D for Geospatial Analysis
Problem #3: Create a Zoning Map from a feature data source.
Solution: Use the Display Manager Task Pane and the Style Editor’s Thematic Mapping
capability to theme polygons by their zoning classification.
Step 1. Connect to Feature data
Click on the Data button in the Display Manager
and select Connect to Data to open the Data
Connect Task Pane.
Select the Add SHP Connection option and
specify the path to the folder containing the
required SHP file. Click the Connect button.
Select the Zoning Schema then click the Add to
Map button to add the zoning polygons to the
map.
Step 2. Stylize Map using Thematic Mapping
Return to Display Manager and click on the
Feature layer to be themed. Select the Style
button to open the Style Editor Task Pane
Click on the New Theme button to open the
Theme Polygons Dialog
In the Theme Polygons area, select the
property to be themed (ie ZONE_CLASS).
Click on the […] button to open another dialog
to specify a Style range
In the foreground color range area, select Color
palette and the Land Cover 1 palette. Click OK
twice. Exit the Style Editor to view the results.
Step 3. Add a legend
Return to Display Manager and click on the
Tools button. Select the Create Legend Option
and insert the legend at a convenient location.
5
Analyze This! How to use AutoCAD Map 3D for Geospatial Analysis
Problem #4: Create a map from point feature data showing USA cities themed by population.
Solution: Use the Display Manager Task Pane and the Style Editor’s Thematic Mapping
capability to stylize points (by color and size) representing USA cities and their population.
Step 1. Stylize Map using Thematic
Mapping
Connect to a suitable point feature source
representing cities and their populations.
In the Display Manager, click on the Feature
layer to be themed. Select the Style button to
open the Style Editor Task Pane.
Click on the New Theme button to open the
Theme Points Dialog
In the Theme Points area, select the property
to be themed (ie POPULATION) and set the
Distribution to Jenks’s (Natural Breaks). Click
on the […] button to open another Dialog to
specify a Style range.
Set the Symbol to circle. Set the size context
to Map Space and the units to Miles. Choose
Expressions for the Width Range and Height
Range, respectively, to reveal the Expression
Builder Dialog. Enter the expression
‘Population / 12000’ (without the quotes) and
select OK in each case.
Specify the fill color ranges going from light to
dark colors.
Click OK twice. Exit the Style Editor to view
the results.
6
Analyze This! How to use AutoCAD Map 3D for Geospatial Analysis
Problem #5: Combine county polygons (stored in a SHP file) and tabular income data (stored in
a MS Access database) and create a thematic map based on income. Note that the tabular
income data does not contain geometry.
Solution: Use a Tabular Join to connect two feature data sources and then use the Style Editor
to create a thematic map based on income.
Step 1. Connect to Feature Data
Sources
Click on the Data button in the Display
Manager and select Connect to Data to
open the Data Connect Task Pane.
Select the Add SHP Connection option
and specify the path to the folder
containing the SHP file. Click the Connect
button.
Select the County Schema then click the
Add to Map button to add the county
polygons to the map.
Select the Add ODBC Connection option
and specify the source of the tabular data.
Click on the Connect button.
Connect to the feature source containing
the tabular Income data. Note that the
tabular income data stored in MS Access
does not contain geometry. Therefore, do
not click on the Add to Map button. Simply
close the Data Connect dialog.
7
Analyze This! How to use AutoCAD Map 3D for Geospatial Analysis
Step 2. Create Tabular Join
In the Display Manager, right-click on the
feature layer containing the County
polygons and select the Create a Join
option to reveal the Create a Join dialog.
Note that the primary table is by default set
to the feature source containing the county
polygons. Set the Table to join to area to
the feature source containing the tabular
income data.
Set the value of ‘This column from the left
table’ area to the column containing the
values which uniquely identify each
polygon (ie county name). Now set the
value of ‘Matches this column from the
right table’ area to the corresponding
column for the income data. Note that the
column names between primary and
joining tables may be different; however,
the values need to match. That is, the
county names in the primary table must
also exist in the joining table.
Change the Type of Join to ‘Keep only left
side records with a match’. Set the
‘Relationship with Secondary Records to
One-to-one. Click OK.
8
Analyze This! How to use AutoCAD Map 3D for Geospatial Analysis
Step 3. Stylize Map using Thematic
Mapping
In the Display Manager, click on the
Feature layer to be themed. Select the
Style button to open the Style Editor Task
Pane.
Click on the New Theme button to open
the Theme Polygons Dialog
In the Theme Polygons area, select the
property to be themed (ie INCOME) and
set the Distribution to Equal.
Accept the remaining default stylizations
by clicking OK. Exit the Style Editor to view
the results.
9
Analyze This! How to use AutoCAD Map 3D for Geospatial Analysis
Problem #6: Find all waterlines that are not topologically connected to the waterline network.
Solution: Use Network Topology in Map Explorer to Flood Trace the waterline network.
Step 1. Create Network Topology
Open the waterlines.dwg.
Right-click the Topology item in Map Explorer
and then select the Create Topology option to
open the Create Topology Dialog
In the Topology Type area, select Network
and then enter the Topology Name (ie
WaterlineNetwork). Click Next.
For Select Links, ensure Select all is
selected. Then enter the layer names
containing the waterline objects in the Layers
edit box. Click Next.
For Select Nodes, ensure Select all is
selected. Click Next to accept remaining
defaults.
For Create New Nodes, ensure Create new
nodes is selected. Click Finish to accept
remaining defaults and create the network
topology.
10
Analyze This! How to use AutoCAD Map 3D for Geospatial Analysis
Step 2. Perform Flood Trace on Network
In Map Explorer, click the ‘+’ sign adjacent to
Topology. Right-click on the newly created
network topology to reveal the context menu.
Select Analysis and then Network Analysis to
open the Network Topology Analysis Dialog
For Analysis Type, Select Flood trace. Then
click Next.
For Locations, click on the button adjacent to
Select start point to reveal the AutoCAD Map
drawing. Then Select a point somewhere in
the middle of the waterline network. Press
Enter to return to the dialog. Click Next.
For Resistance and Direction, click Next to
accept the defaults because we intend to
flood trace the entire network.
For Output Methods, Ensure Highlight is
selected and specify a color (ie Red). Ensure
Create Topology is selected and specify a
name for the new topology (ie
WaterFloodTrace). Click Finish to perform the
flood trace analysis and create the
corresponding topology.
Any parts of the network not highlighted in red
are not connected to the rest of the waterline
network.
11
Analyze This! How to use AutoCAD Map 3D for Geospatial Analysis
Problem #7: Currently, address information resides on the Parcel data, but I would prefer this
information be associated to the building footprint data instead.
Solution: Using the Overlay Analysis functionality, we can perform an Intersect Overlay which
will result in a new dataset with combined attributes from both of the datasets.
Step 1. Connect to Required Feature Data
1.
On the Display Manager tab on the Task Pane, Click
the Data button and select Connect to Data...
2.
Choose Add SDF Connection
3.
Give the Connection an appropriate name
4.
Browse to locate the source file
5. Click Connect, Click Add To Map
6. Repeat steps 1 through 6 to connect to the building
footprint data
Step 2. Define Overlay Analysis Parameters
7.
Choose the Analyze tab on the Ribbon bar, and click
the Feature Overlay button.
8.
Specify the input parameters:
Choose the Parcel Layer for the Source, and choose
the Building Footprints Layer for the Overlay.
9.
Click Next
10. Specify the output parameters:
Specify an output SDF filename, and a Layer name
to be displayed in the Layer Manager
11. Click Finish
12
Analyze This! How to use AutoCAD Map 3D for Geospatial Analysis
Step 3. Stylize the Results
12. Select the new resulting layer in the Display
Manager, and click the Style button
13. Click in the swatch area, or click the
the swatch area.
button in
14. Adjust the Border and Fill properties as desired.
13
Analyze This! How to use AutoCAD Map 3D for Geospatial Analysis
Problem #8: Find the total length of watermains located within Zones categorized Industrial.
Solution: Use Feature queries and Feature Overlay to perform an overlay analysis of type Clip.
Create a Computed field to determine individual feature lengths and export the results to a text
field. Use MS Excel to import the text file and compute the total length of pipe.
Step 1. Connect to Feature data
As described in problems #2 and #3, use
the Data button in the Display Manager to
connect to the two SHP files containing
the watermain and zoning features.
Step 2. Query Industrial Zones
Return to the Display Manager and rightclick on the Zoning layer. Then select the
Query to Filter data option to open the
Create Query dialog.
In the ‘Getting Started with Filters’ area,
click ‘Start a simple filter’.
Select ‘ZONE_CLASS, ‘=’ and ‘Industrial’
for Property, Operator and Value fields,
respectively. Click OK.
Only the polygons with a zoning
classification equal to ‘Industrial’ are now
displayed.
14
Analyze This! How to use AutoCAD Map 3D for Geospatial Analysis
Step 3. Perform a Clip Overlay
From the Ribbon Menu, select the
Feature Map tab and then the Feature
Overlay button to activate the Overlay
Analysis dialog.
Fill-in the Source and Overlay fields by
specifying the source and overlay layers
(ie waterlines and zoning, respectively).
Set the Type field to Clip and click Next.
Set the name of the Output file to
waterlines_industrial.sdf.
Set the value of the Layer name area to
waterlines_industrial.
Accept the default values for the Settings
and click Finish.
A new feature layer with the name
waterlines_industrial will be created.
15
Analyze This! How to use AutoCAD Map 3D for Geospatial Analysis
Step 4. Compute Feature Lengths
From the Display Manager, select the
waterlines_industrial feature layer
resulting from the overlay operation of
Step #3.
In the Display Manager, click on the Table
button to reveal the Data Table dialog.
Note that there is no field containing
length values.
Click on the Options button located at the
bottom of the Data Table dialog and
select the Create a Calculation option to
reveal the Create a Calculation dialog.
In the Getting Started with Calculations
area, select Calculate the geometry of
features in this layer.
Choose the Length2D option from the
Geometric pull down menu and select the
Geometry option from the Property pull
down menu. Set the value of the Name
field to WaterlineLength. Click OK.
Note that the length values now appear in
the WaterlineLength field which has been
added to the Data Table.
16
Analyze This! How to use AutoCAD Map 3D for Geospatial Analysis
Step 5. Export Feature Lengths
Still in the Data Table from Step #4, select
the Options button and choose the Select
All option to select all records in the Data
Table.
Now, re-select the Options button and
choose the Export option and specify the
name of the resulting text file containing
the selected Data Table records.
Step 6. Use MS Excel to Sum Lengths
Use MS Excel to open the resulting file
from Step 5. Navigate to the cell just
below the last length value. Use the ∑
button (ie summation) to total the length
values.
17
Analyze This! How to use AutoCAD Map 3D for Geospatial Analysis
Problem #9: Verify that a proposed development site is not within 100 feet of a waterway.
Solution: Use the Feature Buffer tool to create a 100ft buffer around the waterway and then
compare proposed development and buffer locations to ensure that they do not overlap.
Step 1. Connect to Feature data
As described in problems #2 and #3, use the
Data button in the Display Manager to
connect to the two feature data sources
containing the proposed development site
and waterway features.
Step 2. Create Feature Buffer
Select the Waterway feature layer.
From the Ribbon Menu, select the Feature
Buffer option in the Feature Map tab to
reveal the Create Buffer dialog.
Click on the Select Features button and then
select the Waterway feature from the map.
Press Enter to return to the dialog. Now
specify the buffer distance by setting
Distance to 100 and Units to Feet. Give the
Output to Layer and Save to SDF fields
appropriately descriptive values (ie
WaterBuffer100FT). Set the Merge Results
area to No Merging. Click OK.
A 100ft buffer around the selected feature
will be created. Compare the buffer to the
proposed development site to ensure that
there is no overlap.
18
Analyze This! How to use AutoCAD Map 3D for Geospatial Analysis
Problem #10: Create a contour map from a raster surface (DEM) with minor contours every
10m and major contours every 50m (ie every fifth contour).
Solution: Use the Create Contour layer capability from the Ribbon Menu.
Step 1. Connect to Feature data
Click on the Data button in the
Display Manager and select
Connect to Data to open the Data
Connect Task Pane.
Select the Add Raster Image or
Surface Connection option and
specify the path to the folder
containing the required DEM file.
Click the Connect button.
Select the DEM file of interest
under Schema then click the Add to
Map button to add the raster
surface to the map.
Step 2. Create contour map
In Display Manager, select the
feature layer containing the raster
surface. From the Ribbon Menu,
select the Contour Layer option
available in the Raster Layer tab to
open the Generate Contours Dialog
Specify the name of the contour
layer. Set the Contour elevation
interval to 10 Meters and set the
Major contour every to 5. Select
Create contours as Polyline.
Specify the name of the file under
Save contours into filename.
Click OK to generate contour map.
19
Analyze This! How to use AutoCAD Map 3D for Geospatial Analysis
Problem #11: With a DEM as the source, create a map highlighting south facing slopes.
Solution: Use the Display Manager Task Pane and the Style Editor’s Thematic Mapping
capability to highlight slopes on the 3D surface where the aspect is between 135 -225 degrees.
Step 1. Connect to Feature data
Click on the Data button in the Display
Manager and select Connect to Data to open
the Data Connect Task Pane.
Select the Add Raster Image or Surface
Connection option and specify the path to the
folder containing the required DEM file. Click
the Connect button.
Select the DEM file of interest under Schema
then click the Add to Map button to add the
raster surface to the map.
Step 2. Stylize map Style Editor
Return to Display Manager and select the
raster feature layer containing the surface to
be themed. Select the Style button to open
the Style Editor Task Pane
Under Style, choose the Theme option to the
Theme Dialog
Select Aspect for the Property field and enter
1 in the Create rules field. Click OK to return
to the Style Editor.
Click on the Band Detail button. Enter ‘135 –
225’ for the first rule under Thematic Rules. In
the adjacent area under Styles, click on the
down arrow and choose a highlight color (ie
yellow).
Click Apply and Exit the Style Editor to view
the results
20
Analyze This! How to use AutoCAD Map 3D for Geospatial Analysis
Problem #12: I have some large LIDAR datasets with millions of points, how can I work with
these large datasets in AutoCAD Map?
Solution: Using the new Point Cloud object, this LIDAR data can be processed into a Point
Cloud object that can be used in AutoCAD Map. Furthermore, DEM surfaces can then be
generated from the Point Cloud for further analysis.
Step 1 – Create the Point Cloud Index
1. On the Task Pane > Display Manager tab,
click the Tools button and select Create
Point Cloud Index…
2. Click the Add File button to select your
data file, and click Open. Acceptable file
formats include: LiDAR .las, ASCII .xyz,
and Point Clouds .isd
3. Select the file in the Point Cloud Manager
and click the Generate Index button.
Once the processing is complete a green
check mark
will appear.
4. Click the Add to Map button to add the
Point Cloud to the drawing.
Step 2 – Create the Surface
5. Once the Point Cloud has been added to
the drawing, Right-Click on the layer in the
Display Manager and select Create
Surface…
6. In the Create Surface Manager dialog,
select the Point Cloud row, and click the
Generate Surface button. Once the
processing is complete a green check mark
will appear beside the file.
7. Click the Add to Map button to add the
Surface to the drawing.
21
Analyze This! How to use AutoCAD Map 3D for Geospatial Analysis
Problem #13: I have surface (elevation) data, and I would like perform a flood plain analysis.
The Solution: Using a 3D raster surface, we can perform a simple stylization theme based on
the elevation information to indicate water levels.
Step 1. Connect to Feature Data
1.
On the Display Manager tab on the Task Pane, Click
the Data button and select Connect to Data...
2.
Choose Add SDF Connection
3.
Give the Connection an appropriate name
4.
Browse to locate the source file
5. Click Connect, Click Add To Map
6. Repeat steps 1 through 6 to connect to the building
footprint data
Step 2. Connect to the DEM Surface
7.
On the Display Manager tab on the Task Pane, Click
the Data button and select Connect to Data...
8.
Choose Add Raster Image or Surface Connection
9.
Browse to locate the source file
10. Click Connect, Click Add To Map
22
Analyze This! How to use AutoCAD Map 3D for Geospatial Analysis
Step 3. Create a Theme
1.
Select the new resulting layer in the Display
Manager, and click the Style button
2.
Click in the Style swatch area and choose Theme
from the drop-down list.
3.
In the Theme dialog, ensure that Property is set to
Height, and Create 1 rule, and specify a color. Click
OK
4.
In the Style Editor, Click the Band Detail button to
display all of the theme details.
5.
In the first band detail set the elevation range for the
actual water (river) elevation.
Step 4. Adjust theme for visualization
6.
To analyze the effects of an increased flow in the
river, and potential flooding, simply increase the
value of the river elevation to visualize the result.
23
`